Asignar Formula a Rangos Específicos 1

Asignar Formula a Rangos Específicos 1

Código Macro

'Este código agrega una formula a las celdas especificadas...

'Asignar una fórmula a un rango dado
Sub Rangos3()
    ActiveSheet.Cells(2, 1).Formula = "=SUMA(D1:D5)"
End Sub
 

Para agregar un macro, deberá abrir el editor de VBA en el libro de Excel abierto al cual desea agregarlo, mantener apretado la tecla "ALT + F11", luego seleccionar la solapa "INSERTAR", y desde ahí elegir "MODULO".

Y en el módulo pegar el código completo del macro, para luego poder usarlo.

Para Usar el macro, volver a la hoja de Excel de la siguiente manera, mantener apretado la tecla "ALT + F11", o minimizando o cerrando el editor de VBA.

Y en la hoja de cálculo insertar una FORMA o IMAGEN, luego hacerle clic derecho a la misma y seleccionar, "ASIGNAR MACRO", y elegir el macro deseado que de antemano hemos copiado.

Recuerde que el libro de Excel deberá guardarlo como "LIBRO DE EXCEL HABILITADO PARA MACROS"...