TIPO.DE.ERROR (función TIPO.DE.ERROR)

TIPO.DE.ERROR (función TIPO.DE.ERROR)

TIPO.DE.ERROR (función TIPO.DE.ERROR)

 

Este artículo describe la sintaxis de la fórmula y el uso de la función (función: fórmula ya escrita que toma un valor o valores, realiza una operación y devuelve un valor o valores. Utilice funciones para simplificar y acortar fórmulas en una hoja de cálculo, especialmente aquellas que llevan a cabo cálculos prolongados o complejos.) TIPO.DE.ERROR en Microsoft Excel.

Descripción

Devuelve un número que corresponde a uno de los valores de error de Microsoft Excel o devuelve el error #N/A si no existe ningún otro. Use TIPO.DE.ERROR en una función SI para probar un valor de error y devolver en su lugar una cadena de texto, como un mensaje.

Sintaxis

TIPO.DE.ERROR(valor_de_error)

La sintaxis de la función TIPO.DE.ERROR tiene los siguientes argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.):

  • Valor_de_error    Obligatorio. Es el valor de error cuyo número identificador desea buscar. Aunque valor_de_error puede ser un valor de error real, por lo general es una referencia a una celda que contiene la fórmula que desea probar.
Si valor_de_error es TIPO.DE.ERROR devuelve
#¡NULO! 1
#¡DIV/0! 2
#¡VALOR! 3
#¡REF! 4
#¿NOMBRE? 5
#¡NUM! 6
#N/A 7
#OBTENIENDO_DATOS 8
Otro valor #N/A

Ejemplo

Copie los datos de ejemplo en la tabla siguiente y cópielos en la celda A1 de una nueva hoja de cálculo de Excel. Para que las fórmulas muestren resultados, selecciónelas, presione F2 y después presione Entrar. Si lo necesita, puede ajustar los anchos de columna para ver todos los datos.

Datos    
#¡NULO!    
#¡DIV/0!    
Fórmula Descripción Resultado
=TIPO.DE.ERROR(A2) Número del error #NULO!(1). 1
=SI(TIPO.DE.ERROR(A3)<3;ELEGIR(TIPO.DE.ERROR(A3);"Los rangos no se intersecan";"El divisor es cero")) Comprueba la celda A3 para averiguar si contiene el valor de error #¡NULO! o el valor de error #¡DIV/0!. Si es el caso, se usa el número del valor de error en la función de hoja de cálculo ELEGIR para mostrar uno de los dos mensajes; de lo contrario, se devuelve el valor de error #N/A. El divisor es cero